Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installation sur MELE
#31
(11-29-2013, 09:07 PM)Many77 Wrote: tiramiseb,

j'ai téléchargé l'image mele dispo sur http://calaos.fr/download/experimental/
j'ai refait la même procédure et là.... au miracle, cela fonctionne.
big smile lorsque j'ai vu apparaître "mele IP 192.168.1.2" sur mon routeur !!!

C'est cool que ca marche !
On sais pourquoi l'interface démarre pas, cette image est non fonctionnelle, c'est pour ca que j'avais donné la mienne. Par contre au niveau du boot elle devraient être complètement identiques .....
Pourrais tu essayer de refaire la carte SD avec mon image et réessayer un boot ?
J'ai l'impression qu'on a un comportement complétement ératique. Et je me demande si le fait que tu ais booter dépends de l'image ou de la chance.

On a fait plus de recherche avec Raoul sur cette mele a2000g et il faut qu'on régénère une image spécifiquement pour elle. On vous fera essayer lorsqu'elle sera prête.
Reply
#32
J'ai essayé ton image avec le boot de l'autre image(en récupérant les fichiers u-boot,script et uImage) mais ça ne fonctionne pas.... même problème.
many77, équipé WAGO 750-849 + MeleA2000G
Reply
#33
En fait le boot c'est la premiére partition sur laquelle il y a le uImage (noyau linux), le script.bin (fichier de configuration du processeur et de la carte électronique) et également les premiers secteurs de la carte SD, qui eux ne sont pas visibles sous forme de fichiers. C'est lors de la copie avec DD que ces secteurs la sont copiés directement sur la SD. je vais regarder si il y a une différence sur ce point.

Peut tu me dire si l'image de Raoul, celle sur http://calaos.fr/download/experimental est tout le temps fonctionelle ?
Reply
#34
L'image de Raoul est tout le temps bootable, mais calaos-home ne se lance pas.
J'ai créé une image de la partition mele qui fonctionne (sudo dd if=/dev/sdc1 of=/home/user/boot.img) (j'avais préalablement copié le fichier script.bin)
J'ai ensuite copier TON image vers ma carte sd (sudo dd if=calaos-image-mele.a10-sdimg of=/dev/sdc)
J'ai débranché et rebranché la clé
J'ai écrasé ta partition mele par l'image faite juste avant (sudo dd if=/home/user/boot.img of=/dev/sdc1)
Ensuite j'ai copié mes fichiers io.xml et rules.xml vers /dev/sdc2/etc/calaos/
J'ai mis ma carte SD dans mon MELE..... attendu 2 minutes puis je me suis connecté en SSH.
J'ai pu lancer calaos-home sans problème !

J'ai maintenant un serveur MELE qui boot sur la carte SD et j'ai une interface graphique qui se lance correctement.Big GrinBig GrinBig Grin

Merci Captain et Raoul !
many77, équipé WAGO 750-849 + MeleA2000G
Reply
#35
(12-01-2013, 07:45 PM)Many77 Wrote: L'image de Raoul est tout le temps bootable, mais calaos-home ne se lance pas.
J'ai créé une image de la partition mele qui fonctionne (sudo dd if=/dev/sdc1 of=/home/user/boot.img) (j'avais préalablement copié le fichier script.bin)
J'ai ensuite copier TON image vers ma carte sd (sudo dd if=calaos-image-mele.a10-sdimg of=/dev/sdc)
J'ai débranché et rebranché la clé
J'ai écrasé ta partition mele par l'image faite juste avant (sudo dd if=/home/user/boot.img of=/dev/sdc1)
Ensuite j'ai copié mes fichiers io.xml et rules.xml vers /dev/sdc2/etc/calaos/
J'ai mis ma carte SD dans mon MELE..... attendu 2 minutes puis je me suis connecté en SSH.
J'ai pu lancer calaos-home sans problème !

J'ai maintenant un serveur MELE qui boot sur la carte SD et j'ai une interface graphique qui se lance correctement.Big GrinBig GrinBig Grin

Merci Captain et Raoul !


Petit bémol : a peine 1 heure plus tard, nous nous sommes retrouvés dans le noir. Calaos_server à planté !.... ajoutez à cela les moqueries de ma femme.....Dodgy
je vais affiner les scénarios avec calaos_installer et je réessaierais !

s'il j'ai un moyen de savoir pourquoi ca a planté, dites le moi pour que je vous remonte les infos.
many77, équipé WAGO 750-849 + MeleA2000G
Reply
#36
Hum, je pense comprendre ce que tu as fait, mais vraiment je vois pas comment ca a pu marcher.
J'ai compilé une image dédié pour la mele a2000g.
Peut tu me dire si ça marche mieux ?

http://enna.me/files/calaos-image-meleg-...unxi-sdimg

Au moins si ca boot Smile
Reply
#37
Alors bonne nouvelle... je boot comme il faut sur meleg......What else ? Nothing !
j'arrive à me connecter en SSH, j'arrive à démarrer calaos-server et calaos-home.
J'arrive même à démarrer les 2 services pour un montage automatique.
Par contre je ne pense pas que la connexion à l'automat ait fonctionné (je ne me suis pas trouvé dans le noir), et j'ai aucun flux VGA (écran en veille).

mais ....ça boot ! Wink
many77, équipé WAGO 750-849 + MeleA2000G
Reply
#38
Salut,

Je confirme que chez moi aussi, avec l'image de Raoul ça fonctionne bien. Je n'ai pas approfondi la chose + que ça : JMW passe chez moi cette semaine pour charger l'automate que j'ai reçu il y a moins d'une semaine Smile.
Sébastien Maccagnoni-Munch - Maison en autorénovation, on ne garde que les murs
Automate Wago 750-849 (mais pas de KNX), centrale Beaglebone Black, Calaos 2.0, détecteurs de mouvement HC-SR501, éclairage LED, gradation DALI
Sonorisation Squeezebox avec Raspberry Pi (piCorePlayer), Kia Soul EV en charge toutes les nuits...
Reply
#39
(12-02-2013, 05:43 PM)captainigloo Wrote: Hum, je pense comprendre ce que tu as fait, mais vraiment je vois pas comment ca a pu marcher.
J'ai compilé une image dédié pour la mele a2000g.
Peut tu me dire si ça marche mieux ?

http://enna.me/files/calaos-image-meleg-...unxi-sdimg

Cette image boot correctement et calaos-server fonctionne.
Par contre, j'ai aucune sortie vidéo en VGA (pas testé en hdmi).
many77, équipé WAGO 750-849 + MeleA2000G
Reply
#40
J'ai fait des nouvelles images:
http://calaos.fr/download/experimental/

Il y a une image mele, une image meleg et une image rpi.
Il faut faire attention de prendre la version g que si vous avez une mele a1000G ou a2000G. La version G a plus de memoire et toute la memoire n'est pas mappé si vous prenez l'autre image.

Merci de me donner un retour de ce qui marche et marche pas....
Raoul,
Calaos Core Dev.
Calaos git sur NUC NUC5PPYH | Wago 750-849 | DALI RGB | Sondes NTC sur 750-464 | Sondes 1Wire DS18B20 avec adaptateur USB DS9490R | Nodes MySensors avec gateway USB | Ecran tactile ELO avec adaptateur USB/RS232 | Squeezebox Duet et Radio | Logitech Harmony Ultimate | Ampli Pioneer VSX921
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)