Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installation sur MELE
#91
Hello,

Il n'y a qu'à flasher l'image? Pas besoin de copier le bon script.bin avec la nouvelle image?

En SSH (avec WinSCP), le repertoire \etc\calaos n'existe pas, j'ai le message d'erreur suivant à la connexion :
La commande 'cd "/etc/calaos"'
a échoué avec pour code de retour 2 et pour message
-sh: cd: line 30: can't cd to /etc/calaos..

Je suis obligé de le créer. Je copie ensuite les fichiers de config toujours en SSH.

Quand je lance les commandes systemctl enable calaos-server et systemctl enable calaos-home j'ai les erreurs suivantes :

/etc/calaos$ systemctl enable calaos-server
ln -s '/lib/systemd/system/calaos-server.service' '/etc/systemd/system/multi-user.target.wants/calaos-server.service'

Quand je demande le status :

/etc/calaos$ systemctl status calaos-server
calaos-server.service - Calaos home automation server service
Loaded: loaded (/lib/systemd/system/calaos-server.service; enabled)
Active: inactive (dead)

Le redémarrage du processus fonctionne :

/etc/calaos$ systemctl restart calaos-server

Il se passe la même chose avec calaos-home par contre je n'ai rien à l'affichage sur l'écran tactile meme après restart de calaos-home.
Calaos-server & Calaos-home on mele a1000g with Elotouch 1537L and USB/RS232 converter | Wago controller 750-849 | DALI module (RGB) | Calaos-os V2.0 Stable | Ampli Onkyo TX-NR636
Reply
#92
Pour le script.bin et les mele/cubieboard il faut quand meme copier le fichier comme auparavant. Cette etape est inevitable pour le moment...

Le repertoire /etc/calaos n'est pas crée par defaut. Par contre il est crée automatiquement par calaos_server lors de son démarrage. Mais tu peux le créer a la main aussi...

Concernant le lancement des services, il ne faut pas confondre les commandes "systemctl enable ..." et "systemctl start ...".
La commande enable ne lance pas le service, mais configure le lancement automatique au prochain demarrage. (ce que tu as sur la ligne des commande ne sont pas des erreurs...)

Par contre calaos-home devrait se lancer. Que dit la commande "systemctl status calaos-home" ?
Raoul,
Calaos Core Dev.
Calaos git sur NUC NUC5PPYH | Wago 750-849 | DALI RGB | Sondes NTC sur 750-464 | Sondes 1Wire DS18B20 avec adaptateur USB DS9490R | Nodes MySensors avec gateway USB | Ecran tactile ELO avec adaptateur USB/RS232 | Squeezebox Duet et Radio | Logitech Harmony Ultimate | Ampli Pioneer VSX921
Reply
#93
J'ai à nouveau flashé l'image et copier le script.bin pour la MeleG et c'est bon calaos-server tourne et calaos-home se lance sur l'ecran tactile (je pense que la première fois, je n'avais pas démarré (start) calaos-home avant de faire "enable").

Test du Widget notes et horloge OK mais je n'arrive pas à régler l'heure dans la configuration de calaos-home

La WebApp est bien plus réactive Smile Vraiment sympa avec le Smartphone! Les états des lumières sont à jour dynamiquement maintenant sur la WebApp par contre les VRE n'apparaissent pas dedans, je n'ai que les lumières et les prises commandées.

J'ai des spots LED RVB, les 3 couleurs n'apparaissent pas séparément dans la WebApp. Par contre pilotage OK des LED RVB dans calaos-home.

J'ai testé un scénario simple (2 spots DALI allumé à 5%) sur BP OK mais non fonctionnel sur calaos-home et la webapp (j'avais le même comportement sur l'image d'avant).

Voila pour le moment ce que j'ai pu testé! La Beta de la V2 approche Big GrinBig Grin
Calaos-server & Calaos-home on mele a1000g with Elotouch 1537L and USB/RS232 converter | Wago controller 750-849 | DALI module (RGB) | Calaos-os V2.0 Stable | Ampli Onkyo TX-NR636
Reply
#94
Pour la date et l'heure il faut le faire a la main. En fait calaos-os est deja parametré pour regler l'heure automatiquement par internet. Le seul pb c'est que par defaut c'est pas le bon fuseau horaire. Pour la france il faut faire ca:

Code:
rm /etc/localtime
ln -s /usr/share/zoneinfo/Europe/Paris /etc/localtime

Concernant les volets dans la webapp, ils devraient etre affichés. Tu as quoi comme volet? des WOVolet ou des WOVoletSmart?

Pour le RGB dans la webapp c'est normal, c'est pas fini cette partie la.

Pourrais tu donner plus d'infos concernant ton pb de scenario simple qui ne marche pas sur calaos_home?
Raoul,
Calaos Core Dev.
Calaos git sur NUC NUC5PPYH | Wago 750-849 | DALI RGB | Sondes NTC sur 750-464 | Sondes 1Wire DS18B20 avec adaptateur USB DS9490R | Nodes MySensors avec gateway USB | Ecran tactile ELO avec adaptateur USB/RS232 | Squeezebox Duet et Radio | Logitech Harmony Ultimate | Ampli Pioneer VSX921
Reply
#95
Ok pour la date et l'heure, fuseau modifié manuellement.

Je n'ai que des volets WOVoletSmart dans la maison (vérifié dans le io.xml)

J'ai ajouté une variable scenario avec Calaos_Installer V1.4 (condition sur un BP et action sur 2 transfos DALI à 5%) j'ai ensuite copié la config à jour avec WinSCP. Le scenario fonctionne sur le BP. Le scénario apparait dans calaos-home et la webapp mais quand je clique dessus rien ne se passe, j'ai loupé une étape?
Calaos-server & Calaos-home on mele a1000g with Elotouch 1537L and USB/RS232 converter | Wago controller 750-849 | DALI module (RGB) | Calaos-os V2.0 Stable | Ampli Onkyo TX-NR636
Reply
#96
Salut,

J ai donc installé la nouvelle image pour meleg , nickel pour les widgets sur calaos-home, j ai juste un souci sur la partie audio ou je vois bien mes squeezebox mais je ne peux plus naviguer pour choisir mes musiques (peut etre que j ai un souci de paramétrage avec LMS si sa marche chez qq un d'autre merci de me le dire et je regarderais mon pb )

Concernant les widgets il n'y pas la possibilité d'agrandir l horloge (normal ou pas?)

Sur le webapp ok pour mise à jour dynamique des états, juste pour infos perso "les autres onglets ne sont pas actifs, car quand je clique sur Music ou Security je me dirige tjs sur https://192.*.*.*/#/desktop/home" (je suppose que le webapp n'est pas rendu la)

En tout cas merci super boulot, si y a besoin de tester autre chose, je suis là.
Résumé installation:
WAGO 750-881 , Server Calaos sur mele a2000g, 2 RPI servant à xbmc et squeezebox et 2 RPI squeezebox, 1 RPI pour LMS 7.8.0 ,Nas synology DS414 , GCE Eco device pour gestion énergie,Logitech Harmony Ultimate pour télécommande , Caméra Foscam FI9821EP.
Reply
#97
Hello
Petite question bête, après cette fois un flashage qui a fonctionné correctement (j'ai dû faire une bêtise la première fois, pourtant je n'en suis pas à mon premier flash :x )
J'ai deux partitions sur la carte sD, l'une contient déjà un script.bin, je l'écrase avec celui que j'ai récupéré ?

Je vois que les retours sont bons sinon, super! J'ai hâte de tester ça sur l'installation du collègue !
Reply
#98
Avec la dernière image, j'ai aussi dû mettre a jour manuellement le script.bin (en écrasant l'ancien) avec ma Mele A1000G pour que ca fonctionne...
Calaos-server & Calaos-home on mele a1000g with Elotouch 1537L and USB/RS232 converter | Wago controller 750-849 | DALI module (RGB) | Calaos-os V2.0 Stable | Ampli Onkyo TX-NR636
Reply
#99
Oki, je viens de tester, ça fonctionne pour moi Smile Merci pour la réponse !
En revanche ça boote sur le VGA et non plus sur le HDMI comme avec l'OS d'origine de la MELE, et j'ai le clavier en qwerty par défaut; Pas vous ?

Ah et puis j'ai eu un début d'interface graphique, seulement la souris affichée sur un fond noir. Mais j'ai pas encore exécuté les commandes de raoulh donc c'est peut-être pour ça

Je ferai ce qu'il faut demain pour régler tout ça Smile
Reply
Ca boote aussi sur le VGA chez moi. Pour le clavier, je ne sais pas car je n'en ai pas, Ma Mele est connecté en VGA + RS à un ecran tactile.

Oui pareil pour moi avant de lancer les commandes j'avais un écran noir avec le pointeur.
Calaos-server & Calaos-home on mele a1000g with Elotouch 1537L and USB/RS232 converter | Wago controller 750-849 | DALI module (RGB) | Calaos-os V2.0 Stable | Ampli Onkyo TX-NR636
Reply


Forum Jump:


Users browsing this thread: 11 Guest(s)