Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Impossible de connecter serveur à internet
#11
Ok, peux-tu faire un ping d'une adresse directement pour voir si c'est un pb de DNS ou de routage:
ping 8.8.8.8

merci
Calaos v1.1.20 sur Advantech x86 | Calaos Home écran tactile RS232 | Wago 750-841 | DMX RGB LED
Calaos-OS v2.0 sur Advantech x86 | Clé USB
Squeezebox | Raspberry & Scripts maison
Reply
#12
Excusez-moi de ne plus avoir répondu mais ça m'avait tellement rendu dingue que j'avais abandonné à un moment.

Je suis depuis hier passé en V3 sur un NUC6 et le problème revient.

Néanmoins 2 choses importantes, après une première installe ça a marché mais ayant des problèmes avec l'écran tactile j'ai réinstallé et je retombe de nouveau sur le même problème. ça me rend fou, pendant un moment je n'arrivais même pas à faire un ping sur 8.8.8.8 alors que là ça remarche et je ne sais même pas pourquoi.

Par contre, n'importe quelle autre ping sur une adresse en http://www.xxx.YYY ne marche pas.

Merci d'avance,

Flykri
Reply
#13
Salut Flykri,

Je me souviens avoir eu des problemes similaires quand mon ancien serveur v2 etait en DHCP.  Depuis je suis en IP fixe.  Je n'avais pas vraiment chercher a comprendre.

Je ferais ceci dans l'ordre :
ping 192.168.0.1: je suppose que ca marche 
ping 8.8.8.8 : si ca ne marche pas ca doit etre un probleme de routage.  "route -n" affichera la table de routage.
ping calaos.fr : si ca ne marche pas ca doit etre un probleme de DNS.  Tu peux utiliser nslookup pour tester la resolution d'un nom.

Voici ce que ca donne chez moi.

Verifier les lignes Nameservers et Nameservers.Configuration:
Code:
# connmanctl services
*AO Wired                ethernet_b827eb5fdec8_cable
# connmanctl services ethernet_b827eb5fdec8_cable
/net/connman/service/ethernet_b827eb5fdec8_cable
 Type = ethernet
 Security = [  ]
 State = online
 Favorite = True
 Immutable = False
 AutoConnect = True
 Name = Wired
 Ethernet = [ Method=auto, Interface=eth0, Address=B8:27:EB:5F:DE:C8, MTU=1500 ]
 IPv4 = [ Method=manual, Address=192.168.1.10, Netmask=255.255.255.0, Gateway=192.168.1.1 ]
 IPv4.Configuration = [ Method=manual, Address=192.168.1.10, Netmask=255.255.255.0, Gateway=192.168.1.1 ]
 IPv6 = [  ]
 IPv6.Configuration = [ Method=auto, Privacy=disabled ]
 Nameservers = [ 192.168.1.1 ]
 Nameservers.Configuration = [ 192.168.1.1 ]
 Timeservers = [ 192.168.1.1 ]
 Timeservers.Configuration = [  ]
 Domains = [  ]
 Domains.Configuration = [  ]
 Proxy = [ Method=direct ]
 Proxy.Configuration = [  ]
 Provider = [  ]

Dans le fichier resolv.conf tu devrais avoir 127.0.0.1. Je comprends que c'est connman qui recoit les requetes DNS et les redirige vers les serveurs affiches ci-avant.
Code:
# cat /etc/resolv.conf
# Generated by Connection Manager
nameserver ::1
nameserver 127.0.0.1

Test d'une requete DNS. On voit ici que la requete est initialement envoyee a 127.0.01 (localhost).  L'adresse retournee est correcte (91....).
Code:
# nslookup calaos.fr
Server:    ::1
Address 1: ::1 localhost

Name:      calaos.fr
Address 1: 91.121.175.94 mx.calaos.fr

On peut essayer avec le serveur DNS de google 8.8.8.8.  Le serveur affiche est toujour localhost mais le serveur final utilise est bien 8.8.8.8 (pour s'en assure on peut utiliser le fake serveur dnsp.co qui renverra un autre resultat).
Code:
# nslookup calaos.fr 8.8.8.8
Server:    ::1
Address 1: ::1 localhost

Name:      calaos.fr
Address 1: 91.121.175.94 mx.calaos.fr

Maintenant on peut essayer avec le serveur qu'on a configure dans connman.
Code:
# nslookup calaos.fr 192.168.1.1
Server:    ::1
Address 1: ::1 localhost

Name:      calaos.fr
Address 1: 91.121.175.94 mx.calaos.fr

Ces quelques commandes permetront peut-etre de voir d'ou vient le probleme.
  calaos-os-raspberrypi2-v3.0-alpha6-14-g341535a-2021-01-17 on Raspberry Pi 2 ▶ Wago_2.2/wago_881.pro on Wago 750-881 ▶ DS18B20 sensors on Pi GPIO ▶ Node-RED









Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)