Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bug
#1
[attachment=9]J'ai rencontre actuellement un petit souci avec Calaos Installer pour charger mon fichier de configuration après avoir effectuer des modifications (voir image ci joint).
"Erreur de chargement des fichiers"
Si j'utilise une sauvegarde du fichier effectuée avant modification, je parvient a l'ouvrir et a le charger.
Je ne pense pas qu'il y a un problème avec Calaos Installer, mes fichiers doivent être corrompus.

Cordialement
Steeve MARTINS
Calaos User

Calaos v3 sur Intel BOXNUC5CPYH | Wago 750-842 (2.0)| Eco-Devices
Reply
#2
J'ai le même soucis sur l'un de mes PC's et je soupçonne une mise à jour de Windows 7 d'être à la source du problème....Undecided
En attendant tu peux enregistrer les deux fichiers XML dans un dossier sur ton PC, puis de les uploader manuellement sur le serveur avec par exemple WinSCP (le mot de passe root se trouve sur cette page)
[size=x-small]Calaos v3 sur Intel Nuc NUC5PPYH + écran tactile ELO | Wago 750-881 avec module DALI et module pour sondes de température | RPi+Hifiberry Amp | Eco Device | Logitech Harmony Ultimate | Philips Hue | Sensibo Smart Air Conditioner
Reply
#3
Bizarre comme probleme...

Va falloir que je teste ca...
Raoul,
Calaos Core Dev.
Calaos git sur NUC NUC5PPYH | Wago 750-849 | DALI RGB | Sondes NTC sur 750-464 | Sondes 1Wire DS18B20 avec adaptateur USB DS9490R | Nodes MySensors avec gateway USB | Ecran tactile ELO avec adaptateur USB/RS232 | Squeezebox Duet et Radio | Logitech Harmony Ultimate | Ampli Pioneer VSX921
Reply
#4
du coup j'ai aussi le problème lorsque je veux charger le projet de puis la centrale : Angry

[Image: 750038calaosinstaller2.jpg]

petite précision, je n'ai rien touché depuis mon dernier message et je peux toujours accéder aux fichiers xml avec par exemple Winscp.
j'ai juste fait quelques essais avec calaos installer sur un XP et un Windows 7 fraichement installés mais pareil même soucisUndecided
[size=x-small]Calaos v3 sur Intel Nuc NUC5PPYH + écran tactile ELO | Wago 750-881 avec module DALI et module pour sondes de température | RPi+Hifiberry Amp | Eco Device | Logitech Harmony Ultimate | Philips Hue | Sensibo Smart Air Conditioner
Reply
#5
Bonjour,

Je rencontre aussi ce problème très très embêtant et j'ai toujours eu Windows 7...

Il semble survenir lorsque je crée trop de scénario...

La récupération depuis la centrale se passe sans problème, l'envoi ne passe plus et je suis obligé de repartir d'une sauvegarde plus ancienne.

Mes questions sont donc:
- quel est l'impact de copier les fichiers "io" et "rules" manuellement vers le serveur ?
- comment les faire prendre en compte ? c'est à dire quel genre de reboot applique Calaos Installer ?

Merci
Calaos v1.1.20 | Calaos Home écran tactile RS232 | Wago 750-841 | Squeezebox Touch + Radio
Reply
#6
(02-15-2015, 04:24 PM)Dinuzzo Wrote: Il semble survenir lorsque je crée trop de scénario...
A partir de combien de scénarios ? Quelle sont les tailles des fichier io.xml et rules.xml ?
Quelle version de calaos-server utilises-tu ?

(02-15-2015, 04:24 PM)Dinuzzo Wrote: Mes questions sont donc:
- quel est l'impact de copier les fichiers "io" et "rules" manuellement vers le serveur ?
Tu peux faire ça manuellement ça ne pose pas de problème.

(02-15-2015, 04:24 PM)Dinuzzo Wrote: - comment les faire prendre en compte ? c'est à dire quel genre de reboot applique Calaos Installer ?
Pour redémarrer calaos-server
Code:
systemctl restart calaos-server
Calaos v2 sur Rpi et MeleA1000 | Eco Device | IPX800 | Karotz | 1Wire | Relais GPIO | Squeezebox
Reply
#7
Merci pour les réponses, j'ai trouvé la cause du problème.

Les CR des scripts (voir PJ) ont fait grossir le fichier "rules" de 3500 lignes (200ko) à 1'500'000 lignes (1.9Mo) en qq mois !
Les CR se multiplient à grande vitesse lors de la manip d'envoi/récup de la configuration vers le serveur.

Cause:
certainement un bug lié à Windows...

Fix temporaire:
nettoyage manuel du fichier, ça devrait dépanner pas mal de gens

Fix définitif:
pas encore trouvé avec ma version de l'installer...


Attached Files Thumbnail(s)
       
Calaos v1.1.20 | Calaos Home écran tactile RS232 | Wago 750-841 | Squeezebox Touch + Radio
Reply
#8
C'est un bug dans calaos installer qui a ete corrigé depuis. Installe la derniere version..
Raoul,
Calaos Core Dev.
Calaos git sur NUC NUC5PPYH | Wago 750-849 | DALI RGB | Sondes NTC sur 750-464 | Sondes 1Wire DS18B20 avec adaptateur USB DS9490R | Nodes MySensors avec gateway USB | Ecran tactile ELO avec adaptateur USB/RS232 | Squeezebox Duet et Radio | Logitech Harmony Ultimate | Ampli Pioneer VSX921
Reply
#9
Perso c'est un autre BUG que je rencontre ...
HTTP error. Le protocole "https" est inconnu

Ping vers le serveur : ok
Affichage dans le navigateur internet : ok (mais pb de certificat)

Dernière version de calaos-installer.

Une idée ?


Attached Files Thumbnail(s)
   
Reply
#10
Bonjour,
J'ai la meme erreur...
Steeve MARTINS
Calaos User

Calaos v3 sur Intel BOXNUC5CPYH | Wago 750-842 (2.0)| Eco-Devices
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)